Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
create grid columns at run time
#1
very simple project.

add 2 columns to grid.
refresh / invalidate / render - nothing help.......

if i will do something like that in the VCL framework it would work....

any body have idea? is it always like this in intraweb?
is there any full documentation for any new components?
dose the demos are relevant to version 15.xxx ++

dose the demo for madexception working? in version 15.xxx

dose atozed have to respect some one how bought there components?

==========================
this is the same project with VCL ehlib components
==========================

procedure TForm12.Button1Click(Sender: TObject);
begin
  DBGridEh1.Columns.Add;
  DBGridEh1.Columns[0].Title.Caption := 'code';
  DBGridEh1.Columns[0].Visible := true;;
  DBGridEh1.Columns.Add;
  DBGridEh1.Columns[1].Title.Caption := 'name';
  DBGridEh1.Columns[1].Visible := true;;
end;

===========================
this is the code in intraweb
===========================
unit Unit1;

interface

uses
  Classes, SysUtils, IWAppForm, IWApplication, IWColor, IWTypes, IWCompButton,
  Vcl.Controls, IWVCLBaseControl, IWBaseControl, IWBaseHTMLControl, IWControl,
  IWjQGrid, Vcl.Forms, IWVCLBaseContainer, IWContainer, IWHTMLContainer,
  IWHTML40Container, IWRegion, IWCompLabel;

type
  TIWForm1 = class(TIWAppForm)
    IWRegion1: TIWRegion;
    IWjQGrid1: TIWjQGrid;
    IWButton1: TIWButton;
    IWLabel1: TIWLabel;
    procedure IWButton1Click(Sender: TObject);
  public
  end;

implementation

{$R *.dfm}


procedure TIWForm1.IWButton1Click(Sender: TObject);
begin
  IWjQGrid1.Columns.Add;
  TjQGridColumn(IWjQGrid1.Columns[0]).Title := 'code';
  TjQGridColumn(IWjQGrid1.Columns[0]).Visible := True;
  IWjQGrid1.Columns.Add;
  TjQGridColumn(IWjQGrid1.Columns[1]).Title := 'name';
  TjQGridColumn(IWjQGrid1.Columns[1]).Visible := True;


  IWjQGrid1.DoRefreshControl := true;
  IWjQGrid1.Refresh;
  IWjQGrid1.Invalidate;

  Self.AsyncRenderComponent(IWRegion1);

  IWLabel1.Caption := ' there are ' + IntToStr(IWjQGrid1.Columns.Count) + ' columns';

end;

initialization
  TIWForm1.SetAsMainForm;

end.


Attached Files Thumbnail(s)
       

.zip   Project1.zip (Size: 54.34 KB / Downloads: 2)
Reply
#2
"if i will do something like that in the VCL framework it would work...."

The web is not the desktop and many things are different as requirements are different.

All demos are sorted between 14 and 15 and most 14 demos run fine in 15 with no significant changes.

Please post a ready to run demo that demonstrates your issue for us to see. Posting code snippets not only often leaves out code that is important and interacts, but slows down support requests as we have to try to recreate the issue from code snippets.

Please post them as a ready to download zip file and it should be ready to run as is with minimal set up if any.
Reply
#3
one demo is provided. it call project1.zip.
it has 0 download. so you didn't see it.
please see and give real answer.

>>>> The web is not the desktop and many things are different as requirements are different.

to create so simple grid and query any other Web Framework can do.

you evevn didn't see there is project attach.
Reply
#4
I did miss the attachment in this thread. In your other threads there are no ready to run projects.

"to create so simple grid and query any other Web Framework can do"

Yet thousands of other users are using it successfully. As do many of the demos.

I will ask Alexandre to look at your zip.
Reply
#5
Quote:Very simple project.

add 2 columns to grid.
refresh / invalidate / render - nothing help.......

if i will do something like that in the VCL framework it would work....

any body have idea? is it always like this in intraweb?

No althought you missed to fill the iwgrid data, yes there could be a bug


is there any full documentation for any new components?

Normally there are demos

dose the demos are relevant to version 15.xxx ++

All demos can be compailed and rum with latets intraweb, speacially those from IW 14 and 15

dose the demo for madexception working? in version 15.xxx

If you have exception just add it and they should work

dose atozed have to respect some one how bought there components?

Yes they are, you can also go to the support chat in telegram and you can have directly support from Intraweb users:  https://t.me/IntraWebEn



I have reviewed you demos, you have some issues inyou code and you missed to populate the grid. But yes there is aissue with jqgrid regarding adding new columns after the page is rendered.

Check the project I have modified.
Reply
#6
(07-17-2020, 08:28 PM)fduenas Wrote:
Quote:Very simple project.

add 2 columns to grid.
refresh / invalidate / render - nothing help.......

if i will do something like that in the VCL framework it would work....

any body have idea? is it always like this in intraweb?

No althought you missed to fill the iwgrid data, yes there could be a bug


i just want to show you the bug - not to show you i can fill the grid.... 

is there any full documentation for any new components?

Normally there are demos
no - normaly is 1 documentation  with all feathers + demo

dose the demos are relevant to version 15.xxx ++

All demos can be compailed and rum with latets intraweb, speacially those from IW 14 and 15

dose the demo for madexception working? in version 15.xxx

If you have exception just add it and they should work

dose atozed have to respect some one how bought there components?

Yes they are, you can also go to the support chat in telegram and you can have directly support from Intraweb users:  https://t.me/IntraWebEn



I have reviewed you demos, you have some issues inyou code and you missed to populate the grid. But yes there is aissue with jqgrid regarding adding new columns after the page is rendered.

Check the project I have modified.
did you fix the bug

to fill data - i now how
Reply
#7
Ni I didnt fix the bug, Im not part of atozed team,. But I have reported it, and hope the issue will be fixed.
Reply
#8
Try to be humble next time.
thanks any way
Reply
#9
I have been humble, that's why I took some time answered you, check and and modify the demo, to show the correct way to call the update,e vent here is a Bug with Jqgrid.
I pointed that there is a Bug in The jqGrid since the beginning. The demo is not to show you how to fill it. Juts how to make test for bug testing. Because support team will also need it.

I never said, you where wrong in your report, or if I fixed the bug. Just wanted to give some clearance about the bug report and how to reproduce wihout making code mistakes.
Reply
#10
(07-19-2020, 06:55 AM)mazluta Wrote: Try to be humble next time.
thanks any way

If you follow here long enough you'll see that what appear to be simple problems usually are not simple problems.  A lot of people are using IW and Delphi in different ways, usually not even realizing the differences.  IW works well, so bugs are going to be "in hidden spots", or related to a new feature but not yet observed when they are found.  

A very specific example really is important, otherwise they may not be able to find a bug for weeks if at all.  To be honest, some are bugs, most are just not understanding what's going on.  A user created demo is critical in either finding the bug, or if it's something else then helping the user figure that out.

For future reference:
    https://www.atozed.com/intraweb/support/demos/

Thanks,
Dan
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)