Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Missing entry point in IW15.2.17
#1
Hi,

I have installed IW15.2.17 and get an error message when starting C++ Builder 10.4.
I am now back to IW15.2.15.


Regards
Juergen


Attached Files Thumbnail(s)
   
Reply
#2
I confirm. I got the same error message too after installing IW 15.2.17 over IW 15.2.15.
RAD Studio Delphi 10.4


Attached Files Thumbnail(s)
   
Reply
#3
Hi!

Before the new instalation, did you run full unistall and IWBundledRemovalTool??
Reply
#4
After installing C ++ Builder 10.4 I used IWBundledRemovalTool.exe before the first manual IW installation.
Only the content of the IW installation directory and the content of the C ++ Builder public BPL directory need to be deleted before any further IW installation.

The file with the absolute path specified in the error message definitely comes from the installation of IW15.2.17.

There is no file with the same name on the system anywhere else.
Reply
#5
IW 15.2.17 was built with RAD Studio 10.4.1. You said that you installed the update but I don't get that error.

The file that's referenced in the message box is IntraWeb runtime package but the method it is calling is from RAD Studio IDE itself (it is not a code in IW that is failing but a method in RAD Studio IDE which seems to be wrong - i.e. wrong address)

Are you using pure C++ Builder or RAD Studio IDE?
Reply
#6
No, I had not yet installed the C ++ Builder Update 10.4.1 because I didn't know about it.
But now I've installed it and IW15.2.17 works with it.

Thanks for your help.

Regards
Juergen
Reply
#7
Great. Thanks for the feedback
Reply
#8
Hello.
I've tried updating the IntraWeb several times. I can't do it. 
I tried to update IW to version 15.2.17 and to version 15.2.18. I can not.
Are there detailed update instructions?

I have Windows 10, Delphi 10.4, Intraweb 15.2.15 installed on my computer.

I saved the process of one of my update attempts as an attachment. 
Help me please. What did I do wrong?


Attached Files
.docx   Removing IW 15.docx (Size: 978.63 KB / Downloads: 2)
Reply
#9
You probably have to update to Delphi 10.4.1

Please also note the following contributions:

https://www.atozed.com/2020/09/intraweb-15-2-18/

https://www.atozed.com/forums/thread-2000.html
Reply
#10
(09-25-2020, 08:45 AM)I.Igor Wrote: I've tried updating the IntraWeb several times. I can't do it. 

What does exactly "I can't do it"  mean? Are you getting any error when installing? Do you get any error when it starts up? I see one error message that you were getting but this is before the recommendation to update it to RAD Studio 10.4.1. Did you update it?

As mentioned before, IW 15.2.17+ is built with RAD Studio 10.4.1, so it is recommended that you update your RAD Studio to the latest version.

Also, please download and run the very latest IntraWeb Bundled Removal Tool (updated last week to support RAD Studio 10.4.1 too):

https://www.atozed.com/intraweb/bundled/removal-tool/

It will remove all files from previous versions that come with RAD Studio (even 10.4.1 contains a few files).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)