Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 650
» Latest member: Hullcity007
» Forum threads: 998
» Forum posts: 5,099

Full Statistics

Online Users
There are currently 113 online users.
» 0 Member(s) | 110 Guest(s)
Bing, Google, Yandex

Latest Threads
Check this out! IntraWeb ...
Forum: IntraWeb General Discussion
Last Post: Rolphy Reyes
9 hours ago
» Replies: 7
» Views: 176
New demo: IWGrid + DataTa...
Forum: IntraWeb General Discussion
Last Post: ShaneStump
05-29-2020, 03:30 PM
» Replies: 5
» Views: 849
IdHTTPServer and session ...
Forum: Indy General Discussion
Last Post: rlebeau
05-28-2020, 06:42 PM
» Replies: 3
» Views: 47
IWAppCache question - ctO...
Forum: IntraWeb General Discussion
Last Post: Alexandre Machado
05-28-2020, 07:35 AM
» Replies: 1
» Views: 43
Ciphers
Forum: IntraWeb General Discussion
Last Post: zsleo
05-27-2020, 07:02 AM
» Replies: 17
» Views: 307
Bootstrap
Forum: IntraWeb General Discussion
Last Post: ShaneStump
05-27-2020, 12:33 AM
» Replies: 1
» Views: 62
CheckActiveFormInSync sho...
Forum: IntraWeb General Discussion
Last Post: gerritschurer
05-26-2020, 01:39 PM
» Replies: 2
» Views: 63
First time runing Error!
Forum: COSMOS General Discussion
Last Post: Quajak
05-26-2020, 09:12 AM
» Replies: 7
» Views: 108
Reported security issue v...
Forum: IntraWeb General Discussion
Last Post: joel
05-25-2020, 06:29 PM
» Replies: 4
» Views: 155
System.BadimageformatExce...
Forum: CrossTalk General Discussion
Last Post: kudzu
05-25-2020, 05:40 PM
» Replies: 5
» Views: 66

 
Wink IW 14 and MADShi 4
Posted by: zsleo - 04-28-2018, 03:49 AM - Forum: IntraWeb General Discussion - No Replies

I have been struggling with inserting IW logged on user session information into my MADshi bug reports.

Thanks to fantastic support and help from both IW (yes, you Alexandre [Image: wink.png]) and MADshi the issue now appears to be resolved.

The caveat is that either or both of IW and MADshi may advise differently....

If you are interested here is the link (http://forum.madshi.net/viewtopic.php?f=4&t=28464).

No need to read all the posts.  The first few posts and the last 3 to 5 posts are the important ones.

All the best...

Print this item

  TIdTCPClient on Linux in Delphi 10.2
Posted by: hsvandrew - 04-27-2018, 10:10 AM - Forum: Indy General Discussion - Replies (1)

Hi guys, I'm having problems with RemObjects Remoting SDK TROSuperTCPChannel which uses TIdTCPClient to communicate.

When setting active = false -> disconnect or destroying the component which does the same thing, there is a 20-30 second delay before the destruction completes.
This doesn't occur with Delphi under Windows 32 or 64bit.

The issue is occurring on Centos 7 64bit in may case, I haven't tested other linux builds at this time.

I've tested identical code in Lazarus with Synapse and don't have any delays destroying their components that have connected to the same server.

I'm just wondering whether you can test TIdTCPClient running on Centos 7 64bit through a Delphi console app connecting to a Windows TIdTCPServer server on a delphi console app and see if you get the same issue or can see/suggest what might be causing it...

Print this item

  IdTCPClient on Android: Connecting to non-active network
Posted by: BartKindt - 04-26-2018, 05:16 AM - Forum: Indy General Discussion - Replies (17)

I am not sure if the Indy system can help here, or that this is a pure Android issue (and forums.embarcadero.com is down again).

Android has an 'Active Network', which is set by the system. I get a notification from the 'ConnectionManager' when Android is changing this 'Active' network.
Problem is that Android claims the active network is "connected" when it has Internet access. NOT when it is in fact connected to a Network!

So I have this situation.
Android is connected to a WIFI network on which runs my Local Database Server. But this WIFI network does NOT have Internet access.
At the same time the Android device is also connected to a 'Mobile' network, which DOES have Internet access.
The ConnectionManager sends a notification that the Active Network is the Mobile network and that the WIFI network is NOT connected (but it is).

My App is aware that on the WIFI my Server is active (because I get a broadcast message from it via the IdUDPServer) on the WIFI network, which includes its IP address).

But when I try to connect to it, this connect request goes out over the Mobile network, NOT to the WIFI network.

So. Is there any way I can force the IdTCPClient to specifically do a 'Connect' to via the WIFI network (of which I can get all details) as opposed to the default 'Active' network?

PS:
I tried to set the BoundIP with the local IP address assigned to the WIFI network; But this does not have any effect:
{code}
IdSSLIOHandlerSocketOpenSSL1 := TIdSSLIOHandlerSocketOpenSSL.Create(nil);
          IdSSLIOHandlerSocketOpenSSL1.SSLOptions.Mode := sslmClient;  // sslmUnassigned
          IdSSLIOHandlerSocketOpenSSL1.SSLOptions.SSLVersions := [sslvTLSv1_2];
          IdSSLIOHandlerSocketOpenSSL1.SSLOptions.Method := sslvTLSv1_2;
          IdSSLIOHandlerSocketOpenSSL1.SSLOptions.VerifyDepth := 0;
          IdSSLIOHandlerSocketOpenSSL1.OnStatusInfo := TDTBEventHandlers.IdSSLIOHandlerSocketOpenSSL1StatusInfo;
          IdSSLIOHandlerSocketOpenSSL1.OnStatus := TDTBEventHandlers.IdSSLIOHandlerSocketOpenSSL1Status;
          IdSSLIOHandlerSocketOpenSSL1.OnVerifyPeer := TDTBEventHandlers.IdSSLIOHandlerSocketOpenSSL1VerifyPeer;
          IdSSLIOHandlerSocketOpenSSL1.PassThrough := true;

          IdTCPClient1.IOHandler := IdSSLIOHandlerSocketOpenSSL1;
          if NetworkData.LocalIP <> '' then
          begin
            IdTCPClient1.BoundIP := NetworkData.LocalIP;
            IdSSLIOHandlerSocketOpenSSL1.BoundIP := NetworkData.LocalIP;
            LocalLog('=== TCPThread.Execute: Connect using BoundIP: '+NetworkData.LocalIP);
          end;
{code}


Thanks, Bart

Print this item

  Embarcadero Squirrel on Vacation Again
Posted by: kudzu - 04-25-2018, 03:18 PM - Forum: IntraWeb General Discussion - Replies (13)

From a few weeks ago. But he (or she) is on vacay again.

https://www.atozed.com/2018/04/embt-squi...ion-again/

Print this item

  Copy to clipboard?
Posted by: cpstevenc - 04-23-2018, 03:22 AM - Forum: IntraWeb General Discussion - Replies (13)

Using 14.2.7 with Tokyo Update 3 , HTTPS enabled.

I have a TIWLabel , that uses RawText = true, which for now is named ( and friendly name) lbl_NumberText

I want to be able to copy the text inside this to the clipboard.

I already know this is tricky in itself, depending on Browser... browser version... http vs https.

Using this as an example @ https://www.w3schools.com/howto/howto_js...pboard.asp

I use the onClick ScriptEvent on a button do just do the javascript code


Code:
var copyText = document.getElementById("lbl_NumberText");
    copyText.select();
    document.execCommand("Copy");
    alert("Copied the text: " + copyText.value);

This appears to not work as it never gets to the "alert" section .... I assume the script code is aborting as I am sure "lbl_NumberText" for getElementById is not quite correct.

Print this item

  First Page from URL
Posted by: AllBars - 04-21-2018, 01:55 PM - Forum: IntraWeb General Discussion - Replies (6)

Hi I have created a new Intraweb (standalone) app with two forms (blueform and greenform) and have given them URL aliases in the OnConfig handler of the server controller using:

void __fastcall TIWServerController::IWServerControllerBaseConfig(TObject *Sender)
{
TGreenForm::SetURL ("/", "Green.html") ;
TBlueForm::SetURL ("/", "Blue.html") ;
}

The green form is set as the main form

If I try to start a session from a browser with the URL: http://127.0.0.1:8888/Blue.html I don't get the blue form, I get the green form. How can I fix this please?

Once the session has been started, the URL does work

I have Intraweb 14.2.7 Ultimate edition, and am using C++Builder 10.2 update 3

Thanks
Ian

Print this item

  idudpserver max length ?
Posted by: Madammar - 04-20-2018, 01:15 AM - Forum: Indy General Discussion - Replies (3)

i am trying to send a string length more than 9000 to idudpserver but seems idudpserver does not receive more than 1000 length any idea why ?

Print this item

  Intraweb in Evaluation Mode
Posted by: lfeliz - 04-19-2018, 10:26 PM - Forum: IntraWeb General Discussion - Replies (2)

Hello,

I removed  IW14.1.x  form XE3

Ran the installer for 14.2.7, provide my key which expires  in August of 2018 and when I open an IW project, it states license expired, running in evaluation mode.


So, I removed IW,  ran the clean up tool,  rebooted, reinstalled IW 14.2.7 and I still get error, expired, running in val mode.  


Should I request a new key?  (Email already sent  just in case that fixes it.)

Print this item

  Send data from Delphi to web client
Posted by: radub - 04-19-2018, 03:41 PM - Forum: IntraWeb General Discussion - Replies (7)

Hello,

We have IW 14.2 along with XE5.
Our html contains DataTables plugin.
Tu supply data to DataTables we're trying to use a Delphi function but we don't know how to make the function to return this data to the DataTables js function.
We cannot find a way to register either a callback real function (not a procedure), or to pass out/var parameter(s) from the procedure.

Any help, example, demo will be much appreciated!

Thank you

Print this item

Question idSMTP SASL fails under Android..?
Posted by: BartKindt - 04-18-2018, 02:44 PM - Forum: Indy General Discussion - Replies (2)

This post is a copy of the one I just posted on the Embarcadero forum.
Just want to see how it works here.

----
I am stumped by this.

I have my Windows client using IdSMTP to connect to my Linux EXIM4 server.
This always works perfectly.

I copied the entire unit over to my new Android App, that is, I copied the .pas file, and I made a new FMX Form for it on which I copied the exact same selection of SMTP, SSL and SASL etc. components.
I have set these up on the Form in exactly the same way.
Added the same 3 SASL Mechanisms in the IdSMTP and in the same order.
As far as I can see it is all exactly the same.

{code}
   SMTP: TIdSMTP;
    IdSSLIOHandlerSocketOpenSSL1: TIdSSLIOHandlerSocketOpenSSL;
    IdUserPassProvider1: TIdUserPassProvider;
    IdSASLPlain1: TIdSASLPlain;
    IdSASLSKey1: TIdSASLSKey;
    IdSASLCRAMMD51: TIdSASLCRAMMD5;
    IdSASLCRAMSHA11: TIdSASLCRAMSHA1;
    IdSASLLogin1: TIdSASLLogin;

  procedure:
 (Note this works perfectly under Windows)
            if UsePLAINSASL then
            begin
              if Superuser then LocalLog('UsePLAINSASL: Logging in with Username='+AUsername);
              SMTP.Username := AUsername;
              SMTP.Password := APassword;
              IdUserPassProvider1.Username := AUsername;
              IdUserPassProvider1.Password := APassword;
              IdSASLPlain1.LoginAs := AUsername;

              SMTP.AuthType := satSASL;
              SMTP.UseEhlo := true;

              IdSSLIOHandlerSocketOpenSSL1.Port := APort;
              IdSSLIOHandlerSocketOpenSSL1.Host := AHost;
              IdSSLIOHandlerSocketOpenSSL1.ReadTimeout := 10000;

              IdSSLIOHandlerSocketOpenSSL1.SSLOptions.Mode := sslmClient;
              IdSSLIOHandlerSocketOpenSSL1.SSLOptions.Method := sslvTLSv1;
              IdSSLIOHandlerSocketOpenSSL1.SSLOptions.SSLVersions := [sslvTLSv1];

              SMTP.UseTLS := utUseExplicitTLS; // utNoTLSSupport; //
              SMTP.ValidateAuthLoginCapability := true;
            end else
{code}

But the Android system fails with a: "Doesn't support AUTH or the specified SASL handlers!!"

I use the Android-type OpenSSL libraries, which are loaded correctly (and which are also used by the an IdTCPClient when connecting to an IdTCPServer)

When I look at the debug output of the EXIM Server, it seems to me that the SASL authentication HAS in fact finished, because the Server is already in TLS mode and is waiting for its first TLS packet. Which it never gets.

The Server shows this:
{code}
17925 Listening...
17925 Connection request from 62.140.132.204 port 18027

17927 SMTP>> 220 apollo.bart.gen.nz ESMTP Exim 4.80 Wed, 18 Apr 2018 13:24:42 +0200
17927 Process 17927 is ready for new message
17927 smtp_setup_msg entered
17927 SMTP<< EHLO localhost
17927 localhost in helo_lookup_domains? no (end of list)
17927 sender_fullhost = (localhost) [62.140.132.204]
17927 sender_rcvhost = [62.140.132.204] (helo=localhost)
17927 set_process_info: 17927 handling incoming connection from (localhost) [62.140.132.204]
17927 host in pipelining_advertise_hosts? yes (matched "*")
17927 host in auth_advertise_hosts? yes (matched "*")
17927 host in tls_advertise_hosts? yes (matched "*")
17927 SMTP>> 250-apollo.bart.gen.nz Hello localhost [62.140.132.204]
17927 250-SIZE 52428800
17927 250-8BITMIME
17927 250-PIPELINING
17927 250-AUTH PLAIN
17927 250-STARTTLS
17927 250 HELP
17927 SMTP<< STARTTLS                  <<<<<<<<<<<<<<<<<
17927 initialising GnuTLS as a server
17927 GnuTLS global init required.
17927 initialising GnuTLS server session
17927 Expanding various TLS configuration options for session credentials.
17927 certificate file = /etc/exim4/exim.crt
17927 key file = /etc/exim4/exim.key
17927 TLS: cert/key registered
17927 verify certificates = /etc/ssl/certs/ca-certificates.crt size=272519
17927 Added 172 certificate authorities.
17927 Initialising GnuTLS server params.
17927 Loading default hard-coded DH params
17927 Loaded fixed standard D-H parameters
17927 GnuTLS using default session cipher/priority "NORMAL"
17927 host in tls_verify_hosts? no (option unset)
17927 host in tls_try_verify_hosts? no (option unset)
17927 TLS: a client certificate will not be requested.   <<<<<<<<<<<<<<<<<<<<<
17927 SMTP>> 220 TLS go ahead                            <<<<<<<<<<<<<<<<<<<<<
17927 Received TLS SNI "sartrack.nl" (unused for certificate selection)
17927 gnutls_handshake was successful                   <<<<<<<<<<<<<<<<<<<<
17927 TLS: no certificate from peer ((nil) & 0)
17927 cipher: TLS1.0:DHE_RSA_AES_256_CBC_SHA1:256
17927 Have channel bindings cached for possible auth usage.
17927 sender_fullhost = [62.140.132.204]
17927 sender_rcvhost = [62.140.132.204]
17927 set_process_info: 17927 handling incoming TLS connection from [62.140.132.204]
17927 TLS active                              <<<<<<<<<<<<<<<<<<<<<<<<<
17927 Calling gnutls_record_recv(0x7f323331eae0, 0x7f32336060a0, 4096)  <<<<<<<<<<<<<<< Its waiting here.

17927 SMTP<< EHLO localhost           <<<<<<<<<<<<<<<<<<<<<< It seems the Client is trying again???
17927 localhost in helo_lookup_domains? no (end of list)
17927 sender_fullhost = (localhost) [62.140.132.204]
17927 sender_rcvhost = [62.140.132.204] (helo=localhost)
17927 set_process_info: 17927 handling TLS incoming connection from (localhost) [62.140.132.204]
17927 host in pipelining_advertise_hosts? yes (matched "*")
17927 host in auth_advertise_hosts? yes (matched "*")
17927 tls_do_write(0x7f32333012b8, 132)
17927 gnutls_record_send(SSL, 0x7f32333012b8, 132)
17927 outbytes=132
17927 SMTP>> 250-apollo.bart.gen.nz Hello localhost [62.140.132.204]
17927 250-SIZE 52428800
17927 250-8BITMIME
17927 250-PIPELINING
17927 250-AUTH PLAIN
17927 250 HELP
17927 Calling gnutls_record_recv(0x7f323331eae0, 0x7f32336060a0, 4096)      <<<<<<<<<<<< Waiting again. It stops here.

{code}
 

---
Bart Kindt
CEO & Developer
SARTrack Limited New Zealand
http://www.sartrack.nz

Print this item