Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error reading form : "IWServerController"
I have the follow problem:

- I have RAD 10.2.3.
- I uninstall INTRAWEB.
- I Download and I Used the remove tools.
- I Download the INTRAWEB 14.
- I Install INTRAWEB 14.

I created a INTRAWEB PROJECT and made some change to test.
When i close my rad and open it again, and try to open my INTRAWEB PROJECT, i have a lots of errors.

Error reading form "IWServerController", and my form lost a properties.
   - Appname.
   - Descripcion.
   - DisplayName.
   - Port.
   - Etc.

The form lost all properties for a INTRAWEB project.

- I think that is a problems for this instalation.
- I used a notebook wihout developer software.
- I install RAD 10.2.3. WHITOUT intaweb packetg.
- I install INTRAWEB 14.

And i have de same result.

I have a complete project in intraweb, if i used the RAD 10.2.3 intraweb packetg, I DON'T HAVE PROBLEMS, but my port of connection change and only use from my localhost.
If i use then INTRAWEB 14, may be i can do some changes i my project and build it, and i can use a fixed port and i can use then project from others computers of my lan.
But after any time, wihout error message of the rad, i try to compiler o build then project and the error
Error reading form : "IWServerController" began and NOT DISAPEAR.

If i uninstall ALL RAD AND INTRAWEB, and install again, i can use for a few times, but ever have the same problem.

Can help my, because i develo a completed proyect and i left to the end the problems of fixed port and access from other computers because i thinked the solution was only change the version, but with intraweb 14 i have and unstable tool.
After installing the update, do you see components in the component palette / toolbox for IntraWeb? Is the IntraWeb package listed and loaded in your package list?
(12-27-2018, 06:10 PM)kudzu Wrote: After installing the update, do you see components in the component palette / toolbox for IntraWeb? Is the IntraWeb package listed and loaded in your package list?
Yes, and more, i can use this components a few times, and can compiler and build de project, but in one moment, i close the rad and when i open again the problems begans. Never the rad give me a error, only when i open again the project and try to build the error appears. If open IWServerController forms, y beleave the especialy property of this kind the forms desapears.
If i try to use the wizard to generate a new project, the wizard end the job, but when i try to open it, the same error appears.
Hi Raul. You are executing Delphi/Install/Remove as Administrator?
Hi Jose, yes i Install and remove as administrator, and the extrange is that i can use the intraweb tools and compiler and build a few times, and after of two o three times rad open, the rad dont recognize the especial propierties of IWServerController
There are generally 2 cases that cause what you see:

1) Left over parts of an older IW build.

2) Something (possibly some other plugin you have installed) that prevents IW package from being loaded sometimes. Once a package fails to load Delphi will not auto load it again without user intervention.
Hello Kudzu.

1) I try install the rad studio without Intraweb Packet, and after download IW 14 packet and install it. I this way i didn't uninstall nothing.

2) My Rad only have 2 packets, IW and fastreport, nothing more, and the fastreport work.
- Close Delphi IDE
- Run Regedit.exe and look for your BDS key. In general it is:


it can also be under HKEY_LOCAL_MACHINE, but the default is HKEY_CURRENT_USER

- Find sub key named "Disabled Packages"
- Check if you can find any IntraWeb package there. If there is one or more values, just delete them.
- Start Delphi again and see if it works now
Thanks Alexandre for your responde, i don't have nothing under the "- Find sub key named "Disabled Packages"". My next step will be unsinstall the Delphi IDE and install 10.3 and try in this way. If i obtain a diferent responde i will write about it.


Forum Jump:

Users browsing this thread: 1 Guest(s)