Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blank page in Delphi 10.2 and IW14 2.8
I have Delphi 10.2.3. Past week I downloaded my IW Key and last version (IW 14.2.8). I've tried to run some of the sample projects, but for all of them I get a blank page, without any error.

If I install an old version (IW 14.1.12) the samples runs fine, and my test applications as well.

Could you please help me?

Best regards
             Venancio Lasquibar
Does this happen even when trying to run the Guess demo?
Hi Kudzu
Yes, it does.
Are you testing Guess as SA or other? Does view source show anything? What antivirus package do you have?
I'm trying to answer your questions:
1) I'm working only with SA in 2 computers, and in both I get same results
2) Page is completely blank, regardless the code I use. I've tested with Guess, with another Demo projects, and with a form showing a text box and a label. In all the cases, with IW14.1.12 I can see the controls, but with IW14.2.x (I've tried with 2.3 and 2.8) I see only a blank page.
3) Antivirus: Kaspersky Internet Security, default configuration regarding Internet and Ports. The configuration analyzes traffic on ports 80 and 8888. In my application I use another port (34567), with the same behaviour (no data with 2.x, data with 1.12)

I hope this data could help you to diagnose the problem. Thanks
Can you open developer tools in your browser (F12) prior to execute your application and check if there is any error message when loading it?

You should check in the console window and also try to see in the network tab.

Also, could you please make one of those binary files available through Dropbox or Google drive, so I can test it myself?

Kind regards
When run "Guess" in Mozilla I can see this error (F12 - Console): "XML Parsing Error: junk after document element
Line Number 1, Column 203:"
In Chrome: "mixpanel-2-latest.min.js:13 Mixpanel error: "mixpanel" object not initialized. Ensure you are using the latest version of the Mixpanel JS Library along with the snippet we provide."

In IE, I can't see any error.

Kind regards,
It looks like you might have a bad extension installed. I'm not aware of mix panel usage in IW. See here for example:

The fact that this only happens in Chrome but not IE further supports this hypothesis.

I will check the Chrome extensions. But the problem of blank page is the same regardless the explorer I use (Firefox, Chrome, IE)


Try to disabled control of port 8888 in your AV...

Forum Jump:

Users browsing this thread: 1 Guest(s)