Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intraweb VErsion
Hello i am buying the ultimate version of Intraweb to have Htpps possibiliy with Intraweb

Do you know where i can find the verision of Intraweb , i am with Intraweb 15.2.21.

in my program , the form is in cmsecure, and in the controler ssl options are OK, but when i launch the program 
there is an error in chrome that the form is not in secure mode

I don't know why?

thank you


Attached Files Thumbnail(s)
1) How are you launching the program?

2) What does the URL look like in the browser when you get this error? Does it start with http:// or https:// ?
i am in HTTP and not with https it is the problème....

i don't no why because , int he form im am in secure mode "cmsecure"
and in the controle all the variable ofr the SSL Session are OK

error is :
Error details:
Exception message : Secure mode is required for this form.
Depending on the error condition, it might be possible to restart the application.
Exception class : EIWException
Exception address : 00668B2D
Exception Time : 2020-12-22 21:57:53.038

the project is a stand alone program

in the piece , the error

Attached Files Thumbnail(s)
Its doing as you ask. cmSecure says the page can only be accessed securely, ie https://

cmSecure is a PAGE level setting, not an application level setting.

I ask again, how are you launching the application? Have you tried changing the URL you are using to https:// instead of http:// ?

Is your intent for the entire application to be https and not just a single page?
Not 100% sure what you are attempting.

So I'll go with some assumptions.

You are using SA ( stand alone ) compile of the IW app. 

You want the app to be HTTPS / SSL every where.

If so then this.

1) Leave ConnectionMode on the form(s) as cmAny
2) Make sure under sever controller module, that SSLOptions.NonSSLRequest := nsRedirect;
    This will make sure HTTP:// will redirect the browser to HTTPS://
Hello Kudzu and cpstevenc, yes it's like cpstevenc says, it's a standalone program, I'll test your solution
I'll tell you if it works. thank you so much
As cpstevenc says, set the redirect as this will help in final deployment as well.

But you can also set "Use SSL" on the settings menu of the SA app. If you set the redirect option, you wont need this though.
ok I have an Intraweb License issue, as soon as the problem is resolved I try your solutions.
Thank you
Please use the old license as it was registering ok and your issue was not in fact with the license. The old license is valid and you don't need the new one.
201 / 5000
Résultats de traduction
hello and thank you for your advice, the application works in Https mode, I just have one problem, how to reset the session when you launch the pass so as not to get an error message


Forum Jump:

Users browsing this thread: 1 Guest(s)