Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Incorrect size and position of region in IW15
I have Delphi 10.2 Tokyo, and until past week I've used IW 14.2.8 to create an app. I've bought and installed IW 15.0.28 and reinstalled TMS Intraweb controls. Then, my application started to do strange things.  I'm going to describe one.
My application has a welcome form and, when the user chooses an option in a menu, moves to Form 1. This form is fully divided into 6 regions. Region 3 have some data I want to hide or to show, region 4 has a button hide/show, and region 5 has a grid. Region 6 is a footer band. When the user press button in region 4, region 3 hides (visible := False), and region 4 and 5 moves up. Region 4 fills all the remaining space. When user press again the button, Region3 is shown and Region 5 size is recalculated to fill the remaining space. That's the expected behaviour.
When the user clicks in a row in the grid, application opens a new form (so-called Form2, Detail) in same explorer page. This form has read-only information, and the user can only press a button to close this form. Then, Form1 is shown with the same data as before opening Form2. The question is:
  • If Region3 is visible when user opens Form2, when Form2 closes Form1 is shown correctly
  • If Region4 is hidden when user opens Form2, when Form2 closes the layout is:
          - Regions 1, 2 and 6 in its place (OK)
          - Region 4 just after Region 2 (OK)
          - An empty blank band with size aprox. equal to Region 3 height (bad), between Region4 and Region5
          - Region 5 just after the band, as if Region 3 was visible (bad)
I found a way of solve, but not programmatically. If I press button in region 4 (show Region 3) and press it again (hide Region 3) the page layout is corrected, every region is in its place with its corresponding size.
I've tried to execute the code associated to the "hide/show" button when I return from Form2, but doesn't work.

Obviously, I've observed this behaviour since I've installed new versions of both softwares (Intraweb and TMS controls); with the previous versions, the form worked fine.
Am I doing something wrong or, on the other hand, is a bug of Intraweb? Could you please help me with this problem?

 Best regards,

                     Venancio Lasquibar
Is it possible to recreate this issue using IW controls in a separate test application?
Problem solved.
The cause was the property "AsyncPaging" of the table (TTIWDBAdvWebGrid) in region 5.
Thank you for your time.

Best regards,


Forum Jump:

Users browsing this thread: 1 Guest(s)