Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IW15 CPB XE7 64-bit platform
Hi, I am updating some old projects to 64-bit versions.  To that end I have re-ibstalled my trusty C++ Builder XE7 Enterprise in a nice new Windows 7 64-bit PC (it has to be W7), and downloaded the latest IW 15.0.17, installed it (meticulously following the guide and tool for removing pre-existing stuff), and registered it with my licence.

All is well in 32-bit mode, I started regaining familiarity by the simplest possible project, that has just a button that changes caption when clicked.  Compiles and runs fine under 32-bit platform.

So I add 64-bit platform to the project, select same and completely re-build, which all went well until:

[ilink64 Error] Error: Unresolved external 'WinMain' referenced from C:\PROGRAM FILES (X86)\EMBARCADERO\STUDIO\15.0\LIB\WIN64\RELEASE\C0W64.O

Referring to something I found on-line, I ensured that Link with Dynamic RTL is UNCHECKED as is Link with Runtime Packages but still the same error.  Not sure what I have done wrong ?

I've asked Alexandre to take a look at this and respond back.
WinMain is not an IW unit. It seems the issue is other.

Solution here:!topic/...7i3iPptzIs

Also some here, but less info:
Translation of above URL:

[Linker Error] [Linker Error] Unresolved external 'WinMain' referenced from C:\PROGRAM FILES\BORLAND\CBUILDER6\LIB\C0W32.OBJ

1, after saving the file, run the file, the above error will be reported.

2, and later discovered, because to save the file when the cpp file name and project file name written in the same, because the project file is created cpp file with the same name with the project while saving time, as the project's entrance, so then two cpp file of the same name, will be a conflict.
Thank you very much for the prompt reply.

Unfortunately I have not the slightest clue what to do to remedy the problem.  The first reference refers to a 32-bit console application, the second to filenames, but I cannot relate either to what I have to do to remedy the situation.

I repeat, it is an absolute basic IntraWeb application, started as a new IntrWeb project which works in 32-bit platform, but I add 64-bit platform and I get the error.

What do I do ?

Many thanks again,
You have 2 projects correct? One for 32 and one for 64? What are the names of the project files?
Hi, up till now I have one project named Project1.  It built and ran 32-bit version then added 64-bit platform, built that and triex to run that - with the error noted above.

Following your last I first saved the project with a different project name (Project164), set the platform to 64-bit and built that - same error.

Next I started again from scratch, new IW project,completely new and separate directory from anything else, added a button, added 64-bit platform, deleted 32-bit platform.  Built - same error:

[ilink64 Error] Error: Unresolved external 'WinMain' referenced from C:\PROGRAM FILES (X86)\EMBARCADERO\STUDIO\15.0\LIB\WIN64\RELEASE\C0W64.O

Thanks for your continuing help...
Can you create an X64 VCL forms app and compare the project files?

This is an SA app you are having issues with right? They are just normal VCL form apps. Possibly our template is missing something and this could help us locate it.

I could recreate the issue using in C++ Builder XE7. Not sure yet what is causing it, but only affects XE7 (it might be an installation problem or something else, like a corrupted/missing file). I'm working on it and will get back to you on this ASAP.

Kind regards

Forum Jump:

Users browsing this thread: 1 Guest(s)