Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Let's Encrypt error
#1
Hi,

An error occurred when generating an SSL certificate with the Certificate Manager V1.0.2.0 in the Let's Encrypt staging environment (see image).

Regards
JuergenS


Attached Files Thumbnail(s)
   
Reply
#2
I've never seen this error before... Is it possible that you have a different version of OpenSSL DLLs around?
Reply
#3
This are the versions i have used, all in the same directory:

IWCertificateManager.exe 1.0.2.0 (12.06.2021)
libeay32.dll 1.0.2.15 (21.05.2019)
ssleay32.dll 1.0.2.15 (21.05.2019)
Reply
#4
The same versions that I'm using myself.
I've never found this problem. I tried the application recently and it works correctly as usual.

Were you able to get it working or it always gives this same error?
Reply
#5
No, unfortunately I didn't manage it and now got the certificate elsewhere.
But of course I want it to work next time.
So here are a few more questions.

Are the following settings correct, or must nsAccept be used here?

SSLOptions->EnableACME = true;
SSLOptions->NonSSLRequest = TIWNonSSLRequest::nsRedirect;

Do I have to manually create the /.well-known/acme-challenge/ directory or another one below ROOT or is another directory expected or created automatically?

Can I use my own THandler for ACME HTTP requests on port 80 so that I don't have to open the server for HTTP requests in general?
THandlers::Add(L"/.well-known/acme-challenge/", L"", new TIWH_Acme(PathAcmeChallenge));
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)