Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with IWDBGrid Async refresh
#21
Please install IW 15.2.10: https://www.atozed.com/2020/07/intraweb-15-2-10/

Please let me know if it fixes the issues you were having. It should behave exactly as 15.2.7, with a few issues fixed.
Reply
#22
(07-24-2020, 12:42 PM)Alexandre Machado Wrote: Please install IW 15.2.10: https://www.atozed.com/2020/07/intraweb-15-2-10/

Please let me know if it fixes the issues you were having. It should behave exactly as 15.2.7, with a few issues fixed.
Ok, the AV when loading into the browser is gone and
LogoComograma.Picture.LoadFromFile(UserSession.ImagemInicial); 
doesn't throught an AV anymore.

I have the 3 other issues that still remains:

> Even a code for pagination of a IWGrid was working since like ever and now it's not working, nothing happens when hitting the page buttons.
> Also, after a IWDBgrid ASync refresh, when I press a TIWBSbutton to open another form, nothing happens, but before refreshing that IWDBGrid, it open that form.
> Also clicking on a TIWCombobox to change the number of items per page on that IWDBGrid, doesn't do nothing, doesn't refresh.

Again, with v15.2.0 everything is ok.
Reply
#23
Seems that the buttons are not working after the refresh. This is a IWBootstrap only thing because I can't recreate it with standard controls only.

I'll see if I can recreate it and let you know the results.

Thanks for the feedback
Reply
#24
Regarding this one:
> Also, after a IWDBgrid ASync refresh, when I press a TIWBSbutton to open another form, nothing happens, but before refreshing that IWDBGrid, it open that form.

If I do a IWBSButton.RefreshAsyncRender, solves the problem. Hitting the button will open the form.

But with v15.2.10, the problem reported earlier with TFrame modal, doesn't work, even with RenderAsyncEnabled := False;
The modal Frame will open only after a F5.

Updated the test case for you to see.


Attached Files
.zip   Test case.zip (Size: 549.75 KB / Downloads: 2)
Reply
#25
The issue with IWBS controls creating modal windows at runtime has been fixed in our codebase and a new update is being built.
Stay tuned!

Cheers
Reply
#26
Hi Alexandre!
Again, with v15.2.18, the refresh of the grid doesn't work again.
Here it is the same test case from previous post for you to see whats happens.
It start's to be very annoying to have an aplication that do work almost perfectly and all of a sudden and a after an update to a newer version, everything is broken again.
I think this was working with v15.2.10. It works ok with 15.2.17.

Thanks


Attached Files
.zip   test case.zip (Size: 549.71 KB / Downloads: 1)
Reply
#27
(09-30-2020, 11:47 AM)Comograma Wrote: Hi Alexandre!
Again, with v15.2.18, the refresh of the grid doesn't work again.
Here it is the same test case from previous post for you to see whats happens.
It start's to be verry annoying to have an aplication that do work almost perfectly and all of a sudden and a after an update to a newer version, everything is broken again.
I think this was working with v15.2.10. It works ok with 15.2.17.

Thanks

Hi,

If I remember correctly, last time we talked about a problem with IWGrid, you had an issue with grid refresh in async, I asked for a test case showing exactly what was broken. Not sure if you couldn't recreate it anymore or were unable to recreate it in an isolated test case but anyway I didn't get it.

Are you able now to show what is wrong with your grid?
Reply
#28
(10-02-2020, 12:46 PM)Alexandre Machado Wrote:
(09-30-2020, 11:47 AM)Comograma Wrote: Hi Alexandre!
Again, with v15.2.18, the refresh of the grid doesn't work again.
Here it is the same test case from previous post for you to see whats happens.
It start's to be verry annoying to have an aplication that do work almost perfectly and all of a sudden and a after an update to a newer version, everything is broken again.
I think this was working with v15.2.10. It works ok with 15.2.17.

Thanks

Hi,

If I remember correctly, last time we talked about a problem with IWGrid, you had an issue with grid refresh in async, I asked for a test case showing exactly what was broken. Not sure if you couldn't recreate it anymore or were unable to recreate it in an isolated test case but anyway I didn't get it.

Are you able now to show what is wrong with your grid?

I put the test case example in my previous post.
Attatched it again anyway!!


Attached Files
.zip   test case.zip (Size: 549.71 KB / Downloads: 2)
Reply
#29
This time IW is doing what it is supposed to do.

The problem with your project is that you set:

ServerController.RenderAsyncEnabled := False;
IWForm.RenderAsyncEnabled := True;

It should be:

ServerController.RenderAsyncEnabled := True;
IWForm.RenderAsyncEnabled := True;

The form property can disable the global setting but not enable it. Meaning:

RenderAsyncEnabled should be always True for all projects and all forms. This is the default behavior.

*If* you have some specific need in one of your forms you can disabled it for that specific form permanently (i.e. setting it to False at design time) or temporarily (setting it to False when responding to some request). If you disable it globally in the ServerController, this means that it won't be ever be enabled in your application. The grid async refresh needs it to be enabled.

Does it make sense?
Reply
#30
(10-03-2020, 12:48 AM)Alexandre Machado Wrote: This time IW is doing what it is supposed to do.

The problem with your project is that you set:

ServerController.RenderAsyncEnabled := False;
IWForm.RenderAsyncEnabled := True;

It should be:

ServerController.RenderAsyncEnabled := True;
IWForm.RenderAsyncEnabled := True;

The form property can disable the global setting but not enable it. Meaning:

RenderAsyncEnabled should be always True for all projects and all forms. This is the default behavior.

*If* you have some specific need in one of your forms you can disabled it for that specific form permanently (i.e. setting it to False at design time) or temporarily (setting it to False when responding to some request). If you disable it globally in the ServerController, this means that it won't be ever be enabled in your application. The grid async refresh needs it to be enabled.

Does it make sense?

Yes it does. I think, now, that I finally understand how RenderAsyncEnabled works! My bad!
But now, look at my test case again. I have some buttons and by example, I have a button that opens a modal form (the second one from the right) to input some comments.
Nothing happens when I press that button. How can I solve this particularly situation? 
If I go to button "Carrinho" or press F5 on the browser and than close that form, the modal form will open and this is not what to expect..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)