Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Application that runs under 15.1.17 stop working under 15.1.19
I am working using Delphi 10.3.3 Upd 3 on Windows 10 64bit
Due to some problems about opening CGDevTools dialogs after deployed the application as an ISAPI extension I tried to update my IW  from 15.1.17 to 15.1.19.
Using 15.1.17 everything worked fine a part problems opening dialogs.
Under 15.1.19 the application stop running at the begining.

In the TIWUserSession.IWUserSessionBaseCreate I instatiate several data module to permit to access them as a UserSession property:
Connection.Params.Values['Server'] := '(local)';

FFilialiDataModule := TFilialiDataModule.Create(Self);
FListiniDataModule := TListiniDataModule.Create(Self);
FPromozioniDataModule := TPromozioniDataModule.Create(Self);
FUtentiDataModule := TUtentiDataModule.Create(Self);

When I run the program I get an error at the second data module (FListiniDataModule) create call.
The error is about the FireDAC connection on a TFDQuery, which resides in the data module, is not defined.
The connection of the query point to the UserSession connection and the module is correctly in the use clause of the data module.
I tried to explicitly set it in code but nothing changed.

The same code runs well using IW 15.1.17  Huh

Do you have any advice about how to solve this error?

Thank you,
Hi Davide,

please install 15.1.20 and it should fix this issue.

Forum Jump:

Users browsing this thread: 1 Guest(s)