Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Access Violation when using Frames in IW15
#1
Hi - I am trying to track down an AV I get when using frames in an IW 15 application. These are inherited frames, and I have quite a number on the main IW form. The AV happens when a certain sequence of steps is followed.

The Delphi compiler simply tries to open IWApplication.pas when the error happens so of course I can't see quite what's going on, and if the error is in my construction or something in IW itself - my hunch is the latter, but perfectly possible I'm doing something wrong.

If I supply a zip of the source code with steps to reproduce, could somebody at AtoZed look at it for me? The application is confidential so would rather send it to you direct rather than upload here.

I've tried the latest IW 15.1.15 and on both Seattle and Rio IDEs with same results.

Thanks
Richard
Reply
#2
Yes, please send it to alexandre [at] atozed dot com and I'll have a look.

If you have any call stack information when the error happened, it can also help
Reply
#3
Many thanks, will send in the morning.
Reply
#4
Hi Richard,

We have fixed the issue, according to emails we exchanged.

I recommend you to update to version 15.1.7, released this week. After studying your case, I included some code which will prevent that certain types of errors end up causing an AV, more specifically, the "unregistration" by default of Async events of destroyed controls.

Cheers
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)