Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sending email through Gmail
(07-17-2018, 03:05 PM)jjeffman Wrote:
Porta: 587
UseTLS: utNoTLSSupport

You MUST set UseTLS to utUseExplicitTLS when using port 587. That will send the required STARTTLS command.

(07-17-2018, 03:05 PM)jjeffman Wrote: No matter the value I set to the SSLOptions method the error message is the same.

Because the STARTTLS error has nothing to do with the SSL/TLS settings themselves. STARTTLS is an SMTP command to request a SSL/TLS session be created on a currently-unsecure connection.

(07-17-2018, 03:05 PM)jjeffman Wrote: I have just changed some code positions to assure that Port and UseTLS properties have the correct value. The error has changed to :

rY3Dizvx9JK2UC-zyHlRi9VYUyUdD84xr6LeX1qRzZDjbFHtyi> Please log in via
your web browser and then try again."

What am I doing wrong?

Nothing. Google is simply asking you to verify your PC/device before it will then allow an SMTP session from that same PC/device.

(07-17-2018, 03:05 PM)jjeffman Wrote: After going to the limk Gmail sent in the error message and having changed the security options I have succeeded on snding emails through Gmail SMTP.



Messages In This Thread
Sending email through Gmail - by jjeffman - 07-16-2018, 08:19 PM
RE: Sending email through Gmail - by rlebeau - 07-16-2018, 09:21 PM
RE: Sending email through Gmail - by jjeffman - 07-17-2018, 03:05 PM
RE: Sending email through Gmail - by rlebeau - 07-17-2018, 05:38 PM

Forum Jump:

Users browsing this thread: 2 Guest(s)