Atozed Forums
Let's Encrypt error - Printable Version

+- Atozed Forums (
+-- Forum: Atozed Software Products (
+--- Forum: IntraWeb (
+---- Forum: English (
+----- Forum: IntraWeb General Discussion (
+----- Thread: Let's Encrypt error (/thread-2732.html)

Pages: 1 2 3

Let's Encrypt error - JuergenS - 05-07-2022


An error occurred when generating an SSL certificate with the Certificate Manager V1.0.2.0 in the Let's Encrypt staging environment (see image).


RE: Let's Encrypt error - Alexandre Machado - 05-19-2022

I've never seen this error before... Is it possible that you have a different version of OpenSSL DLLs around?

RE: Let's Encrypt error - JuergenS - 05-19-2022

This are the versions i have used, all in the same directory:

IWCertificateManager.exe (12.06.2021)
libeay32.dll (21.05.2019)
ssleay32.dll (21.05.2019)

RE: Let's Encrypt error - Alexandre Machado - 05-27-2022

The same versions that I'm using myself.
I've never found this problem. I tried the application recently and it works correctly as usual.

Were you able to get it working or it always gives this same error?

RE: Let's Encrypt error - JuergenS - 05-27-2022

No, unfortunately I didn't manage it and now got the certificate elsewhere.
But of course I want it to work next time.
So here are a few more questions.

Are the following settings correct, or must nsAccept be used here?

SSLOptions->EnableACME = true;
SSLOptions->NonSSLRequest = TIWNonSSLRequest::nsRedirect;

Do I have to manually create the /.well-known/acme-challenge/ directory or another one below ROOT or is another directory expected or created automatically?

Can I use my own THandler for ACME HTTP requests on port 80 so that I don't have to open the server for HTTP requests in general?
THandlers::Add(L"/.well-known/acme-challenge/", L"", new TIWH_Acme(PathAcmeChallenge));

RE: Let's Encrypt error - jeroen.rottink - 09-19-2022

Hi Juergen and Alexandre,

I got the same error message this morning. Same procedure as last time (1 July 2022) when the same procedure did work.
Using same versions as Juergen.

RE: Let's Encrypt error - JuergenS - 09-19-2022

Hi Jeroen,

the error disappeared by itself in a later intraweb version, but now I'm using IW15.2.64.
Unfortunately, I still couldn't get the intraweb certificate manager to work with Let's Encrypt.

Since I didn't get an answer and there is no example either, I created an ACME handler and tried it with another certificate manager and it worked!

Regards Juergen

RE: Let's Encrypt error - jeroen.rottink - 09-19-2022

Hi Juergen,

I went back to the version of IW I used in July, the last time getting a LE certificate worked. This was IW15.2.55
Even with that version running, the LE error is the same. The version of IW used does not make a difference in my case.
IW15.2.55 15.2.60 and IW15.2.65

Hope we can use it in the future again.

RE: Let's Encrypt error - JuergenS - 09-19-2022

Hi Jeroen,

I think you're right, it wasn't directly because of Intraweb.
I was trying to track down the error and it was probably an exception in Indy.
But I can no longer understand it because I had to reinstall my PC for another reason.

RE: Let's Encrypt error - Alexandre Machado - 09-20-2022

Wait... I'm kind of confused with all the messages. Is it working for your or not?

I've installed a couple of certificates myself using it a couple of weeks ago and everything just worked.