Atozed Forums

Full Version: TIndyHTTPServer 505 error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have to create an application that talks to TIdHTTPServer.

I am using client-side component that surely composes HTTP 1.1 compliant request, yet the server responses with Error 505 - HTTP version not supported.

Any ideas on what could potentially cause that?
(02-04-2019, 07:41 AM)admctfdotcom Wrote: [ -> ]I am using client-side component that surely composes HTTP 1.1 compliant request

Are you SURE about that? Did you actually LOOK at the request? Or are you just ASSUMING?

(02-04-2019, 07:41 AM)admctfdotcom Wrote: [ -> ]yet the server responses with Error 505 - HTTP version not supported.

Nothing in TIdHTTPServer's internal logic uses response code 505, so it has to be getting set by the server's application code instead. For example, maybe the server is receiving an HTTP 1.0 request and wants to only accept HTTP 1.1 requests. That could be done in the TIdHTTPServer.OnHeadersAvailable event.

There is really no way to answer this without seeing the actual request + response, and/or the actual server code.