Atozed Forums

Full Version: Taborder issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am having all kinds of tab order issues.

I would like to manually set my taborder at runtime, but if I try to set the taborder to say 1000 it will immediately changes to say 24.

I must be missing something.  How can I manually control the taborder at runtime?
Hi Joel,

I can't answer your question immediately as my system isn't handy, but I can tell you that one of the first questions others trying to help will want to know are the version of IW and Delphi. If you provide those it will help get a faster answer.

Dan
(08-08-2018, 06:31 AM)DanBarclay Wrote: [ -> ]Hi Joel,

I can't answer your question immediately as my system isn't handy, but I can tell you that one of the first questions others trying to help will want to know are the version of IW and Delphi.  If you provide those it will help get a faster answer.

Dan

Thanks.   I am using iw14.2.8
cg 4.1.0.94
Delphi 10 Seattle
After struggling with the tab order in IW apps every time I added a new field to a screen, I finally ended up programmatically setting the TabIndex, TabOrder and TabStop properties on each of the edit components, in order, when I create the form.

This seems to be the only practical way to ensure the correct tab order.

Also, .ZIndex can be troublesome if you are using dialogs or any type of 'psudo-modal' window.

Just my $0.02 worth.
Scott
(08-08-2018, 01:41 PM)ScottWGast Wrote: [ -> ]After struggling with the tab order in IW apps every time I added a new field to a screen, I finally ended up programmatically setting the TabIndex, TabOrder and TabStop properties on each of the edit components, in order, when I create the form.  

This seems to be the only practical way to ensure the correct tab order.  

Also, .ZIndex can be troublesome if you are using dialogs or any type of 'psudo-modal' window.

Just my $0.02 worth.
Scott

Are you setting these in the onrender or in the oncreate? 

If you use any cgdevtools components do you set the InnerEdit.TabOrder also?
I use OnCreate, then I don't have to worry about it each time the screen is rendered.
Yes, I also use CGDevTools, but I do not set InnerEdit.TabOrder value.

It seems to work as expected and I rarely have tab order issues any more.

HTH!
(08-08-2018, 03:48 PM)ScottWGast Wrote: [ -> ]I use OnCreate, then I don't have to worry about it each time the screen is rendered.
Yes, I also use CGDevTools, but I do not set InnerEdit.TabOrder value.

It seems to work as expected and I rarely have tab order issues any more.

HTH!

That seems to work for the edit boxes.

However, have you worked with some of the other components like TIWCGJQCheckbox.

if I set the TIWCGJQCheckbox.taborder := 2 it always sets it to something different.   See the code below where it changed my 2 that I set in the oncreate to a 1 instead.

<input checked="" id="CHKUSERCODE_CHECKBOX" name="CHKUSERCODE_CHECKBOX" onclick="checkBoxClick(event, 'CHKUSERCODE');" tabindex="1" type="CHECKBOX">
i tried to change the TabIndex, TabOrder and TabStop properties too, but still have problems with some CG controls.
iw and TMS controls works fine for me, but some CG controls really drove me crazy.
i wasted MANY hours on it, so i gave up trying for now...
(08-08-2018, 08:49 PM)EitanArbel Wrote: [ -> ]i tried to change the TabIndex, TabOrder and TabStop properties too, but still have problems with some CG controls.
iw and TMS controls works fine for me, but some CG controls really drove me crazy.
i wasted MANY hours on it, so i gave up trying for now...

Thanks.   I will post something to the cgdevtools forum on the issue.