Atozed Forums

Full Version: TLS 1.2 in Delphi 2007
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I try to send mail with TLS 1.2 in a Delphi 2007 project.
Is that possible ?

I have Indy version 10.2.3 

The  IdSSLIOHandlerSocketOpenSSL1.Method only shows sslvTLSv1. ( and sslvSSLv2,sslvSSLv23,sslvSSLv3  )

If I choose sslvSSLv23, I get very often the error "SSL is not available on this server".
Strange thing is however, that if I keep trying to send the exact same mail, it sometimes does send the mail ...

Any hint is very much appreciated !

kind regards,

Dirk Janssens.
UPDATE :
I Just installed the latest version, and now I can choose sslvTLSv1_2 as Method, but only in code, not in the property-editor. Is that normal ? 
Furthermore, I now get error ( Socket erro #10060 connection timed out ) 

Is it possible I need to update some dll's before getting this to work ? 

If so,  I looked at all the versions on  https://indy.fulgan.com/SSL/  but they all have in the  Requirements:    Indy 10.5.5+ (SVN Version or Delphi 2009 and newer) 
Am I stuck ?


Any help is welcome,

kind regards,

Dirk Janssens.
Hi Dirk, get latest (1.0.2u) DLLs here: https://github.com/IndySockets/OpenSSL-Binaries
Thank you Jose,

just one thing : these also state "(SVN Version or Delphi 2009 and newer)"

Is that no problem, since my project is made in Delphi 2007 ?
(02-24-2021, 10:09 AM)Dirk Janssens Wrote: [ -> ]I try to send mail with TLS 1.2 in a Delphi 2007 project.
Is that possible ?

I have Indy version 10.2.3

No. You need to upgrade to a modern version of Indy. The current version is 10.6.2

(02-24-2021, 01:06 PM)Dirk Janssens Wrote: [ -> ]UPDATE :
I Just installed the latest version, and now I can choose sslvTLSv1_2 as Method, but only in code, not in the property-editor. Is that normal ?

No, it is not. You likely have old BPLs, DCUs, etc still on your system, and the IDE is finding them before finding the newer files. You need to completely wipe out all traces of an older version when upgrading.

(02-24-2021, 01:06 PM)Dirk Janssens Wrote: [ -> ]Is it possible I need to update some dll's before getting this to work ?

Most likely, yes. Indy 10 supports up to OpenSSL 1.0.2u (support for OpenSSL 1.1.x is in-progress: https://github.com/IndySockets/Indy/pull/299), so make sure you have those DLLs in your application folder.

(02-24-2021, 01:06 PM)Dirk Janssens Wrote: [ -> ]If so, I looked at all the versions on https://indy.fulgan.com/SSL/ but they all have in the Requirements: Indy 10.5.5+ (SVN Version or Delphi 2009 and newer)
Am I stuck ?

No, they work just fine with modern Indy.

That repo is dead: https://www.indyproject.org/2020/06/16/o...to-github/

The new repo is: https://github.com/IndySockets/OpenSSL-Binaries
Thank you so much for your respons !