Atozed Forums

Full Version: IW unable to server static files in folder
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi I am trying create a valid SSL certificate withn zeroSSL.

To validate the CSR I choice HTTP option and zeroSSL saids I have to put some files in "{wwwroot}.well-known/acme-challenge/" folder

I am having a problem where IW is unable to server static files when I create ".well-known/acme-challenge/"  into wwwroot.

IW returns an error of "Resource not found".

It seems IW has a problem com "hyphen". I was searching in the google, I can see "hyphen" is a legal char in a URL and doesn´t needs to encode it.
But if I encode it, I also have the same problem.



Code:
127.0.0.1/.well-known/acme-challenge/teste.txt   // here I get resource not found


I did a test changing  the names folder to the next, and it works
Code:
127.0.0.1/.well-known/acme_challenge/teste.txt  // here it works

But I need to use:
Code:
127.0.0.1/.well-known/acme-challenge/teste.txt

I have tried to change  hyphen with "%2D" but no look.

How could I fix it?
Is it a IW bug?

Regards, Luiz
(11-15-2019, 07:32 PM)Jose Nilton Pace Wrote: [ -> ]Hi, read here: https://www.atozed.com/forums/thread-956.html
Thank you. I will try It
But using zerossl or not, I think there is a problem in IW serving static files in folder with hyphens. Just test my sample and you can see the browser is unable to access teste.txt file.
(11-15-2019, 07:32 PM)Jose Nilton Pace Wrote: [ -> ]Hi, read here: https://www.atozed.com/forums/thread-956.html
I think that post is out of date.

sslZero needs the chalenge at ".well-known/acme-challenge/"

But I tested and IW is unable to server files in that folders because the hyphen at  "acme-challenge".

In my tests if I get rid off the hyphen IW is able to find the files.

So, I am sure is a IW Bug.

Here is the error when I try the chalenge:
Code:
Fetching http://techaboutweb.myvnc.com/.well-known/acme-challenge/d9PqipbOYe5GG80xcQg9OSZFkyvhgrgDebTucmyw4QM: Timeout during connect (likely firewall problem)
No it is not a bug. From the aforementioned post:

"...You have to create a folder named "acme-challenge" under your application folder (not wwwroot, but the actual IW application folder) and put the challenge file there."
(11-18-2019, 02:13 AM)Alexandre Machado Wrote: [ -> ]No it is not a bug. From the aforementioned post:

"...You have to create a folder named "acme-challenge" under your application folder (not wwwroot, but the actual IW application folder) and put the challenge file there."
Alexandre, as I said before, zeroSSL documentation says to put the challenge into ".well-known/acme-challenge/' not into "acme-challenge".
If I put into "acme-challenge" zeroSSL is unable to find the challenge and throw an error.

From zeroSSL:
Verification
To verify domain ownership using HTTP verification, you will need to create appropriate files with specific text strings under your "webroot/.well-known/acme-challenge/" directory, where "webroot" is the main directory with your website pages. Please make sure that the files you have created are actually accessible (by clicking the links below in the File column) and have proper content before clicking "Next".
Domain
Filetechaboutweb.myvnc.com
36Uq8wCvx1YEzPxX-hDPDO5-xr7WLi3A_u_GqoAeXXX
Text: 36Uq8wCvx1YEzPxX-hDPDO5-xr7WLi3A_u_GqoCCCCCAeasdfaK4.wAJFtVdbhUdivX8S-P1giJnHHUgpMFrUOgFKvV-eWLc


If i put the challenge into 'acme-challenge" folder as you said I get an error. See my other post please.
Hi. You still don't get it yet. IW takes care of the request for you. You do NOT have to create the ".well-known/" dir, just create the "acme-challenge" dir and put the file in there, that's all.
(11-18-2019, 04:05 PM)Jose Nilton Pace Wrote: [ -> ]Hi. You still don't get it yet. IW takes care of the request for you. You do NOT have to create the ".well-known/" dir, just create the "acme-challenge" dir and put the file in there, that's all.
I did.  It does not work. ZeroSsl  is unable to get a a response from IW using only acme-challenge folder. The response is resource not found
You must not create a .well-known directory and you *must not* put acme-challenge directory inside wwwroot folder.

<Your application folder>
|----- wwwroot
|----- acme-challenge

You must also enable the option under ServerController.SSLOptions
I did.  I enabled ACME in servercontroller and create a folder as you said. I put the challenge  file into folder and this is not working.
zeroSSL is not finding the challenge file in acme-challenge folder

Here is the images with the configs:

https://www.dropbox.com/s/g2y5twc40hjaq5r/ssl1.jpg?dl=0

https://www.dropbox.com/s/p9wlhpxyx3ue57h/ssl2.jpg?dl=0

https://www.dropbox.com/s/tv8ma1hvqmad6ro/ssl3.jpg?dl=0

Regards, Luiz